Salesforce Connector Overview

Versions Supported

The SalesForce API is available to the following versions of Salesforce.

  • Enterprise Edition

  • Unlimited Edition

NOTE on Professional Edition: You may be able to gain access to the REST API if you are on the Professional Edition without upgrading your license. You will need to work with your SFDC Account Manager to see if such an option is available.

Authentication Requirements

The Formstack Sync Salesforce connector uses OAuth so installing the Connector only requires that a valid user log in their credentials from the Connector Settings interface.

mceclip0.png

It is recommended that Administrator credentials are used when authenticating the Connector.

Objects Supported

Each Object below may have a certain set of sub-Objects. Not all sub-Objects are supported by Formstack Sync so it's important to discuss any of these Objects that are important to your integration needs with our sales team.

 

Object

Permissions

Custom Field Support

Dedupe Key

User

Read

Yes

Email

Lead

Read / Update / Create

Yes

Email

Contact

Read / Update

Yes

Email

Person Account

Read / Update / Create

 

Email

Account

Read / Update / Create

Yes

Name

Opportunity

Read / Update

Yes

Closing Date    

Name    

Contact and Company Relationship

API Version and Limits

The Formstack Sync Salesforce connector fully supports the most up-to-date Salesforce API.

Salesforce enforces API Limits based on the Salesforce Edition you're using. You can find a list of these API Limits on the Salesforce API Request Limits page.

Important Consideration(s)

Every Connector has a set of considerations and limitations that can impact how data will flow from one System to another. These may not be the only limitations depending on your integration needs. Make sure to discuss your key integration goals with your Formstack Sync sales representative to ensure we can meet your needs.

  • If you have Custom Objects that you want to incorporate in your Formstack Sync integration, you must install the Force.com Connector. Learn more about Force.com here.

  • If you have Person Accounts enabled, you can sync data for this Object through Formstack Sync.

 

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Article is closed for comments.